Everything's been stable since the fix, so we're closing this incident.
If you're still having trouble getting connected with your Smart SIM, give your phone a quick restart to help it reconnect to the network. If that doesn't do the trick, get in touch with our support team and we'll be happy to help.
Thanks for bearing with us while we got everything back up and running.
Resolved
Everything's been stable since the fix, so we're closing this incident.
If you're still having trouble getting connected with your Smart SIM, give your phone a quick restart to help it reconnect to the network. If that doesn't do the trick, get in touch with our support team and we'll be happy to help.
Thanks for bearing with us while we got everything back up and running.
Monitoring
Good news — it's fixed! Smart SIM is back up and running across all the countries we support. Still having trouble getting connected? Give your phone a quick restart first. If that doesn't do the trick, get in touch with our support team and we'll sort you out.
Investigating
We're working with our supplier to fix this as quickly as we can. Due to longer wait times, we recommend keeping an eye on this page for updates. We'll post an update as soon as it is fixed.
Investigating
We're investigating degraded Smart SIM service for some customers in some markets. We're working with our upstream supplier to resolve as quickly as possible.